OC-20 centrifuge stopped spinning

Collecting, filtering and dewatering of WVO SVO vegetable oil. For Biodiesel producers too.

Moderators: SunWizard, coachgeo

OC-20 centrifuge stopped spinning

Postby Rkmcdon » Sat Nov 22, 2014 9:58 pm

I've filtered about 400 gallons through my oc-20 centrifuge set up in a 55 gallon drum without any trouble over the past 6 months. Last week, without preamble the rotor stopped spinning. It seems to spin freely by hand. I disassembled and cleaned the centrifuged including the spring and piston, and now the rotor spins but won't get up to speed. Here are some pics in case it helps

Here's my setup
Image

Centrifuge disassembled
Image

Image

This is the view through the inlet port with the piston assembly removed
Image

Image

Image

seal in place and arrows lined up
Image

rotor cover seats down easily without having to overtighten the nut
Image

Piston assembly reinstalled
Image

Image

Image

Image

Heres a video (if the link works) to get an idea of the kind of flow i'm getting and the what the rotor is doing. When I shot this, the rotor actually spun for the first time which caught me by surprise, but after shooting I tried a couple more times but never could get even close to sufficient speed.

http://i32.photobucket.com/albums/d8/Te ... 9D99C1.mp4

I hope someone has some ideas.

Thanks
Rodney
1969 FJ55 Project - Planned: 4bt swap, spring over, locking diffs, 35" BFG MT's and of course...veggie power!
Rkmcdon
 
Posts: 13
Joined: Thu Oct 24, 2013 6:39 pm

Re: OC-20 centrifuge stopped spinning

Postby SunWizard » Sun Nov 23, 2014 3:08 pm

Whats the pressure reading?
YVORMV - Your veg. oil results may vary.
95 Dodge Cummins 4x4 SVO WVO conversion.
81 Mercedes 300D- stock and happy on V80/D20 blend.
Low fossil net zero house- 100% solar power and heat.
SunWizard
Site Admin
 
Posts: 1720
Joined: Mon Dec 11, 2006 2:53 pm
Location: N. Colorado

Re: OC-20 centrifuge stopped spinning

Postby Rkmcdon » Sun Nov 23, 2014 4:00 pm

80 psi

If you are able to watch the video, it shows unrestricted flow without the centrifuge; flow with the centrifuge, no rotor; centrifuge, rotor, no cover; and finally, fully assembled. All at 80 psi (except the first which is unrestricted flow).
1969 FJ55 Project - Planned: 4bt swap, spring over, locking diffs, 35" BFG MT's and of course...veggie power!
Rkmcdon
 
Posts: 13
Joined: Thu Oct 24, 2013 6:39 pm

Re: OC-20 centrifuge stopped spinning

Postby SunWizard » Mon Nov 24, 2014 11:57 am

Watched the video, I think you should have much more flow coming out when no rotor at 80psi. So the valve in the base may be sticking. Mine with no rotor would spray all over the room if I ran without the cover like you did.
YVORMV - Your veg. oil results may vary.
95 Dodge Cummins 4x4 SVO WVO conversion.
81 Mercedes 300D- stock and happy on V80/D20 blend.
Low fossil net zero house- 100% solar power and heat.
SunWizard
Site Admin
 
Posts: 1720
Joined: Mon Dec 11, 2006 2:53 pm
Location: N. Colorado

Re: OC-20 centrifuge stopped spinning

Postby Rkmcdon » Mon Nov 24, 2014 6:42 pm

Ok, that helps. I've taken out the piston from the base and cleaned it, so maybe i have an obstruction in the pipes restricting the flow going into the centrifuge. Either that or something is keeping the piston from moving freely even after cleaning the spring, piston and channel they go in. Sadly Ive never tested the flow out of the pipes without the centrifuge in place so i don't have a reference to know what it was like when all was working well.
1969 FJ55 Project - Planned: 4bt swap, spring over, locking diffs, 35" BFG MT's and of course...veggie power!
Rkmcdon
 
Posts: 13
Joined: Thu Oct 24, 2013 6:39 pm


Return to Vegetable oil Collecting, Filtering and Dewatering

Who is online

Users browsing this forum: No registered users and 1 guest